<!DOCTYPE html>
<html lang="zh-cn">
<!--
//                            _ooOoo_
//                           o8888888o
//                           88" . "88
//                           (| -_- |)
//                            O\ = /O
//                        ____/`---'\____
//                      .   ' \\| |// `.
//                       / \\||| : |||// \
//                     / _||||| -:- |||||- \
//                       | | \\\ - /// | |
//                     | \_| ''\---/'' | |
//                      \ .-\__ `-` ___/-. /
//                   ___`. .' /--.--\ `. . __
//                ."" '< `.___\_<|>_/___.' >'"".
//               | | : `- \`.;`\ _ /`;.`/ - ` : | |
//                 \ \ `-. \_ __\ /__ _/ .-` / /
//         ======`-.____`-.___\_____/___.-`____.-'======
//                            `=---='
//
//         .............................................
//                  佛祖保佑             永无BUG
-->
<head>
    <meta http-equiv="Content-Type" content="text/html" charset="UTF-8" >
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="X-UA-Compatible" content="IE=edge, chrome=1">
    <title>PHP7与PHP5共存于CentOS7 - Holmesian Blog</title>
<meta name="theme-color" content="#fff">
 
<meta name="full-screen" content="yes">  
<meta name="x5-fullscreen" content="true">  
        <link rel="icon" id="web-icon" href="/favicon.ico">
        <link rel="apple-touch-icon" href="https://holmesian.org/usr/themes/Holmesian/image/avatar.jpg"/>
<link rel="alternative" type="application/atom+xml" title="RSS" href="https://holmesian.org/feed/">
<meta property="og:image" content="https://holmesian.org/usr/themes/Holmesian/image/avatar.jpg">
<meta property="og:title" content="PHP7与PHP5共存于CentOS7 - Holmesian Blog"/>
<meta property="og:description" content="服务器上除了小部分应用比较老，只能在PHP5下跑，其他应用都能在PHP7下跑，所以在复习建造师考试的空余就折腾了一下共存。思路很简单：PHP5是通过yum安装的在/usr/，套接字在/var/r...">  
<meta property="og:url" content="https://holmesian.org/PHP7-PHP5-on-CentOS-at-the-same-time"/>  
<link rel="alternate" hreflang="zh-Hans" href="https://holmesian.org/PHP7-PHP5-on-CentOS-at-the-same-time" />
<meta itemprop="name" content="PHP7与PHP5共存于CentOS7 - Holmesian Blog">
<meta itemprop="description" content="服务器上除了小部分应用比较老，只能在PHP5下跑，其他应用都能在PHP7下跑，所以在复习建造师考试的空余就折腾了一下共存。思路很简单：PHP5是通过yum安装的在/usr/，套接字在/var/r...">
<meta itemprop="image" content="https://holmesian.org/usr/themes/Holmesian/image/avatar.jpg">
 
 <!--STYLES--> 
    <link rel="stylesheet" href="https://holmesian.org/usr/themes/Holmesian/fontawesome.css" type="text/css">
    <link rel="stylesheet" href="https://holmesian.org/usr/themes/Holmesian/style.min.css" type="text/css">
    <link rel="stylesheet" href="https://holmesian.org/usr/themes/Holmesian/prism.css" type="text/css">
<script type="text/javascript" src="https://holmesian.org/usr/themes/Holmesian/prism.js"></script>

    <style>#yl p{text-indent: 2em;} #yl p iframe{margin-left:-2em;} </style>

    <!--STYLES END-->
   <meta name="description" content="服务器上除了小部分应用比较老，只能在PHP5下跑，其他应用都能在PHP7下跑，所以在复习建造师考试的空余就折腾了一下共存。思路很简单：PHP5是通过yum安装的在/usr/，套接字在/var/r..." />
<meta name="keywords" content="php,nginx,centos" />
<link rel="pingback" href="https://holmesian.org/action/xmlrpc" />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://holmesian.org/action/xmlrpc?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://holmesian.org/action/xmlrpc?wlw" />
<script type="text/javascript">
(function () {
    window.TypechoComment = {
        dom : function (id) {
            return document.getElementById(id);
        },
    
        create : function (tag, attr) {
            var el = document.createElement(tag);
        
            for (var key in attr) {
                el.setAttribute(key, attr[key]);
            }
        
            return el;
        },

        reply : function (cid, coid) {
            var comment = this.dom(cid), parent = comment.parentNode,
                response = this.dom('respond-post-1775'), input = this.dom('comment-parent'),
                form = 'form' == response.tagName ? response : response.getElementsByTagName('form')[0],
                textarea = response.getElementsByTagName('textarea')[0];

            if (null == input) {
                input = this.create('input', {
                    'type' : 'hidden',
                    'name' : 'parent',
                    'id'   : 'comment-parent'
                });

                form.appendChild(input);
            }

            input.setAttribute('value', coid);

            if (null == this.dom('comment-form-place-holder')) {
                var holder = this.create('div', {
                    'id' : 'comment-form-place-holder'
                });

                response.parentNode.insertBefore(holder, response);
            }

            comment.appendChild(response);
            this.dom('cancel-comment-reply-link').style.display = '';

            if (null != textarea && 'text' == textarea.name) {
                textarea.focus();
            }

            return false;
        },

        cancelReply : function () {
            var response = this.dom('respond-post-1775'),
            holder = this.dom('comment-form-place-holder'), input = this.dom('comment-parent');

            if (null != input) {
                input.parentNode.removeChild(input);
            }

            if (null == holder) {
                return true;
            }

            this.dom('cancel-comment-reply-link').style.display = 'none';
            holder.parentNode.insertBefore(response, holder);
            return false;
        }
    };
})();
</script>
<script type="text/javascript">
(function () {
    var event = document.addEventListener ? {
        add: 'addEventListener',
        focus: 'focus',
        load: 'DOMContentLoaded'
    } : {
        add: 'attachEvent',
        focus: 'onfocus',
        load: 'onload'
    };

    document[event.add](event.load, function () {
        var r = document.getElementById('respond-post-1775');

        if (null != r) {
            var forms = r.getElementsByTagName('form');
            if (forms.length > 0) {
                var f = forms[0], textarea = f.getElementsByTagName('textarea')[0], added = false;

                if (null != textarea && 'text' == textarea.name) {
                    textarea[event.add](event.focus, function () {
                        if (!added) {
                            var input = document.createElement('input');
                            input.type = 'hidden';
                            input.name = '_';
                            input.value = (function () {
    var _P0m = '1ab'//'sed'
+'4'//'fq'
+'22'//'4V'
+'50'//'2'
+'63'//'8R'
+'sjR'//'sjR'
+'68e'//'W'
+//'m15'
'3a'+//'N'
'd7'+//'jHi'
'755'+'6l6'//'6l6'
+//'H4'
'H4'+'8'//'Y'
+/* 'Kzn'//'Kzn' */''+''///*'XzA'*/'XzA'
+''///*'O'*/'O'
+//'J'
'J'+//'BY'
'4f'+''///*'4'*/'4'
+'42'//'n'
+''///*'SO'*/'SO'
+//'a'
'a'+'bc'//'1'
+//'h9'
'h9'+'e1'//'lx3'
+/* 'lqt'//'lqt' */''+'3ba'//'N5'
, _HAX = [[10,13],[20,23],[20,22],[21,22],[25,26],[27,29]];
    
    for (var i = 0; i < _HAX.length; i ++) {
        _P0m = _P0m.substring(0, _HAX[i][0]) + _P0m.substring(_HAX[i][1]);
    }

    return _P0m;
})();

                            f.appendChild(input);
                            added = true;
                        }
                    });
                }
            }
        }
    });
})();
</script>
<link rel="stylesheet" type="text/css" href="https://holmesian.org/usr/plugins/HighSlide/css/highslide.css" />
<!--[if lt IE 7]>
<link rel="stylesheet" type="text/css" href="https://holmesian.org/usr/plugins/HighSlide/css/highslide-ie6.css" />
<![endif]-->
 
</head>

    <body><div id="sos">
        <div id="blog">
        <!--[if lt IE 9]>
		 <div class="browsehappy" role="dialog">当前网页 <strong>不支持</strong> 你正在使用的浏览器. 为了正常的访问, 请 <a href="http://browsehappy.com/">升级你的浏览器</a>.</div>
	    <![endif]-->

 



<header id="header"  
data-behavior="1">


  <i id="btn-open-sidebar" class="fa fa-lg fa-bars"></i>
    <h1 class="header-title">
        <a class="header-title-link" href="https://holmesian.org/" >Holmesian Blog</a>
    </h1>
   <a  class="header-right-icon st-search-show-outputs"
                id="sou">        
                <i class="fa fa-lg fa-search"></i>
            </a>    
</header>

  


 <nav id="sidebar"  
data-behavior="1">

 
 <div class="sidebar-profile">
            <a href="/#about">
                    <img class="sidebar-profile-picture" src="https://holmesian.org/usr/themes/Holmesian/image/avatar.jpg"/> </a>
        <span class="sidebar-profile-name">Holmesian Blog</span> 
        </div>
    
    
        <ul class="sidebar-buttons">
        
            <li class="sidebar-button">
                
                    <a  class="sidebar-button-link " href="https://holmesian.org/" >
                
                    <i class="sidebar-button-icon fa fa-lg fa-home" ></i>
                    <span class="sidebar-button-desc">Home</span>
                </a>
        </li>
        
            <li class="sidebar-button">
                
                    <a  class="sidebar-button-link "
                         href="https://study.holmesian.org"
                        
                    >
                
                    <i class="sidebar-button-icon fa fa-lg fa-bookmark"></i>
                    <span class="sidebar-button-desc">Study</span>
                </a>
        </li>
        
            <li class="sidebar-button">
                
                    <a  class="sidebar-button-link "
                         href="/archive"
                        
                    >
                
                   <i class="sidebar-button-icon fa fa-lg fa-calendar"></i>
                    <span class="sidebar-button-desc">Archive</span>
                </a>
        </li>
        
            <li class="sidebar-button"  id="sou">
                
                    <a  class="sidebar-button-link st-search-show-outputs" >
                
                    <i class="sidebar-button-icon fa fa-lg fa-search"></i>
                    <span class="sidebar-button-desc">Search</span>
                </a>
        </li>
   
            <li class="sidebar-button">
                
                    <a  class="sidebar-button-link "
                         href="/#about"
                        
                    >
                
                    <i class="sidebar-button-icon fa fa-lg fa-info-circle"></i>
                    <span class="sidebar-button-desc">About</span>
                </a>
        </li>
        
    </ul>
    
        <ul class="sidebar-buttons">
 
         
                   <li class="sidebar-button">
                
                    <a  class="sidebar-button-link " href="https://twitter.com/sholmesian" target="_blank" >
                
                    <i class="sidebar-button-icon fa fa-lg fa-twitter"></i>
                    <span class="sidebar-button-desc">Twitter</span>
                </a>
        </li>

<li class="sidebar-button">
                
                    <a class="sidebar-button-link " href="/message">
                
                      <i class="sidebar-button-icon fa fa-lg fa-chain"></i>
                    <span class="sidebar-button-desc">Links</span>
                </a>
        </li>
    </ul>
    
</nav>


   <div id="main"  data-behavior="1"class="hasCoverMetaIn" >



<article class="post" itemscope itemType="http://schema.org/BlogPosting">
    
<div class="post-header main-content-wrap text-left">
    
                     <h1 class="post-title" itemprop="headline">  PHP7与PHP5共存于CentOS7    </h1>    
    <div class="post-meta">
    <time itemprop="datePublished" content="2017-08-29  22:55:45">
	
		 Aug 29,2017    	
    </time>
    
        <span>in </span>
        
    <a class="category-link" ><a href="https://holmesian.org/sort/Daily/">日积月累</a></a> <span>lang </span>
            <a class="category-link"    id="translateLink" href="javascript:translatePage();">繁</a> 
               </div>

</div>
    
 <div class="post-content markdown" itemprop="articleBody">
        <div class="main-content-wrap" id="yl"><tree id="mulu"></tree>     <p>服务器上除了小部分应用比较老，只能在PHP5下跑，其他应用都能在PHP7下跑，所以在复习建造师考试的空余就折腾了一下共存。思路很简单：PHP5是通过yum安装的在/usr/，套接字在/var/run/php-fpm.socket，PHP7自己编译装在/usr/local/php7，套接字在/var/run/php7-fpm.socket，nignx根据应用需要跑的环境指定fastcgi_pass。</p><h1>编译并安装PHP7</h1><p>先通过yum来安装编译需要的各种依赖包</p><pre><code class="lang-bash">    yum install libxml2 libxml2-devel openssl openssl-devel bzip2 bzip2-devel libcurl libcurl-devel libjpeg libjpeg-devel libpng libpng-devel freetype freetype-devel gmp gmp-devel libmcrypt libmcrypt-devel readline readline-devel libxslt libxslt-devel -y</code></pre><p>接着到<a href="http://php.net/downloads.php" target="_blank">官网</a>下载最新的PHP源码（现在是7.1.8），解压</p><pre><code class="lang-bash">    cd ~
    wget http://am1.php.net/distributions/php-7.1.8.tar.gz
    tar xvf  php-7.1.8.tar.gz
    cd php-7.1.8</code></pre><p>然后设置编译参数，这里有几个事情要提一下：</p><ol><li><p>为了减少后续因为权限导致的问题，建议将nginx和php-fpm用相同的用户和用户组即（--with-fpm-user=nginx --with-fpm-group=nginx）。</p></li><li><p>为了减少多网卡等复杂网络环境造成的问题，在不使用ipv6网络的情况下关闭ipv6的支持(--disable-ipv6)。</p></li><li><p>开启mysql数据库的API扩展（--with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd ）</p></li><li><p>开启opcache扩展（--enable-opcache）</p></li></ol><p>完整的编译参数如下：</p><pre><code class="lang-bash">    ./configure \
    --prefix=/usr/local/php7 \
    --with-config-file-path=/usr/local/php7/etc \
    --with-config-file-scan-dir=/usr/local/php7/etc/php.d/ \
    --disable-ipv6  \
    --enable-fpm \
    --with-fpm-user=nginx  \
    --with-fpm-group=nginx \
    --enable-inline-optimization \
    --disable-debug \
    --disable-rpath \
    --enable-shared  \
    --enable-soap \
    --with-libxml-dir \
    --with-xmlrpc \
    --with-openssl \
    --with-mcrypt \
    --with-mhash \
    --with-pcre-regex \
    --with-sqlite3 \
    --with-zlib \
    --enable-bcmath \
    --with-iconv \
    --with-bz2 \
    --enable-calendar \
    --with-curl \
    --with-cdb \
    --enable-dom \
    --enable-exif \
    --enable-fileinfo \
    --enable-filter \
    --with-pcre-dir \
    --enable-ftp \
    --with-gd \
    --with-openssl-dir \
    --with-jpeg-dir \
    --with-png-dir \
    --with-zlib-dir  \
    --with-freetype-dir \
    --enable-gd-native-ttf \
    --enable-gd-jis-conv \
    --with-gettext \
    --with-gmp \
    --with-mhash \
    --enable-json \
    --enable-mbstring \
    --enable-mbregex \
    --enable-mbregex-backtrack \
    --with-libmbfl \
    --with-onig \
    --enable-pdo \
    --with-mysqli=mysqlnd \
    --with-pdo-mysql=mysqlnd \
    --with-zlib-dir \
    --with-pdo-sqlite \
    --with-readline \
    --enable-session \
    --enable-shmop \
    --enable-simplexml \
    --enable-sockets  \
    --enable-sysvmsg \
    --enable-sysvsem \
    --enable-sysvshm \
    --enable-wddx \
    --with-libxml-dir \
    --with-xsl \
    --enable-zip \
    --enable-mysqlnd-compression-support \
    --with-pear \
    --enable-opcache</code></pre><p>设置检查通过之后就是喜闻乐见的make和make install了，有兴趣的可以在make install之前make test一下。</p><h1>配置PHP7</h1><p>make install无错安装成功之后就开始进行配置，首先将默认配置复制到指定位置，</p><pre><code class="lang-bash">    cp php.ini-production /usr/local/php7/etc/php.ini
    cp /usr/local/php7/etc/php-fpm.conf.default /usr/local/php7/etc/php-fpm.conf
    cp /usr/local/php7/etc/php-fpm.d/www.conf.default /usr/local/php7/etc/php-fpm.d/www.conf
    cp -R ./sapi/fpm/php-fpm.service /usr/lib/systemd/system/php7-fpm.service</code></pre><p>然后按照需求进行修改，必须修改的内容有：</p><ol><li><p>/usr/local/php7/etc/php-fpm.d/www.conf中：</p></li></ol><pre><code class="lang-bash">    listen = /var/run/php7-fpm.socket</code></pre><p>listen的位置就是nignx中fastcgi_pass的unix套接字地址。</p><ol><li><p>/usr/local/php7/etc/php.ini中：</p></li></ol><pre><code class="lang-bash">    pdo_mysql.default_socket=/var/lib/mysql/mysql.sock</code></pre><p>由于PHP从5.x开始，PHP连接MYSQL无论使用哪种方式都是使用的mysqlnd驱动，且PHP7已经正式移除了mysql扩展，由于新特性的原因，PHP7针对数据库主机地址为localhost和127.0.0.1时分别会采用unix domain socket和TCP/IP两种不同的方式连接MySQL服务。</p><p>而采用unix domain socket方式时PHP7会使用默认的/tmp/mysql.sock作为套接字，但是CentOS7默认MySQL服务MariaDB的套接字位置为/var/lib/mysql/mysql.sock，于是即使是所有数据库连接信息都正确的情况下也会出现诸如“mysqli::real_connect(): (HY000/2002): No such file or directory ” 和 “Error establishing a database connection”之类的错误提示。</p><p>为了避免这个莫名其妙的问题，请将pdo_mysql.default_socket修改为MySQL服务的socket地址。</p><pre><code class="lang-bash">    cgi.fix_pathinfo=0</code></pre><p>默认cgi.fix_pathinfo=1，这是一个曾经产生了大面积安全风险的默认设置项，虽然现在PHP-FPM已经做了安全过滤，但是出于安全考虑还是在php.ini中也关闭吧。pathinfo功能在nginx里可以通过正则来实现。</p><pre><code class="lang-bash">    date.timezone =&quot;Asia/Hong_Kong&quot;</code></pre><p>修改时区，避免时间混乱的情况。</p><pre><code class="lang-bash">    disable_functions = exec,passthru,popen,proc_open,shell_exec,system,assert,chroot,delete,rmdir,rename,chgrp,chmod,chown,copy,mkdir</code></pre><p>关闭部分可能带来危险的函数，如果没有特殊需求的话建议加上。</p><pre><code class="lang-bash">    zend_extension=/usr/local/php7/lib/php/extensions/no-debug-non-zts-20160303/opcache.so
    [opcache]
    opcache.force_restart_timeout=3600
    opcache.memory_consumption=128
    opcache.optimization_level=1
    opcache.max_accelerated_files=4096
    opcache.revalidate_freq=60
    opcache.fast_shutdown=1
    opcache.enable=1
    opcache.enable_cli=1</code></pre><p>Zend OPcache通过opcode缓存和优化避免重复编译，减少CPU和内存开销提供更快的PHP执行速度，作为PHP7的高性能扩展之一，不开可惜哦～  这部分内容可以单独形成ini文件放在/usr/local/php7/etc/php.d/目录下，也可以直接添加在php.ini中，启用之后最好在phpinfo中确认Zend OPcache状态正常。</p><p>其他日志权限之类的常规配置就不再赘述，配置完了就添加自启并启动PHP-FPM服务</p><pre><code class="lang-bash">    systemctl enable php7-fpm.service
    systemctl start  php7-fpm.service</code></pre><h1>配置Nginx</h1><p>这个不多说，对能够在PHP7上跑的vhost，将其fastcgi_pass改到PHP7的套接字上就好了</p><pre><code class="lang-bash">    fastcgi_pass  unix:/var/run/php7-fpm.socket;</code></pre><p>对了，在nginx中实现pathinfo之后，记得在fastcgi_params中加上</p><pre><code class="lang-bash">    try_files $uri = 404;</code></pre><p>用来阻止不必要的数据传到后端php7-fpm，先这样吧，下次再来填坑。</p> </div>
    </div>
    <div class="post-footer main-content-wrap">
        
        
 
        
        
            <div class="post-footer-tags"> 
                <span class="text-color-light text-small">TAGGED IN</span><br/>


<nav class="tag tag--primary tag--small t-link" style=" display: inline-block;">  
<a href="https://holmesian.org/tag/php/">php</a></nav><nav class="tag tag--primary tag--small t-link" style=" display: inline-block;"><a href="https://holmesian.org/tag/nginx/">nginx</a></nav><nav class="tag tag--primary tag--small t-link" style=" display: inline-block;"><a href="https://holmesian.org/tag/centos/">centos</a>
</nav>  </div>        
        <div class="post-actions-wrap">
    <nav>
        <ul class="post-actions post-action-nav">
            <li class="post-action">
       <a class="post-action-btn btn btn--default tooltip--top" href="https://holmesian.org/OCSP-Stapling"  data-tooltip="记录OCSP Stapling的两个问题"> <i class="fa fa-angle-left"></i><span class="hide-xs hide-sm text-small icon-ml">PREVIOUS  </span></a>
            
          
            </li>
            <li class="post-action">
                        <a class="post-action-btn btn btn--disabled" target="_blank">
<span class="hide-xs hide-sm text-small icon-mr">NEXT</span>
                    <i class="fa fa-angle-right"></i></a>
                 </li>
        </ul>
    </nav>
  <ul class="post-actions post-action-share">
        <li class="post-action hide-lg hide-md hide-sm">
            <a class="post-action-btn btn btn--default btn-open-shareoptions"  href="#btn-open-shareoptions">
                <i class="fa fa-share-alt"></i>
            </a>
        </li> <li class="post-action hide-xs">
<a class="post-action-btn btn btn--default" target="_blank" data-tooltip="分享至Google"  href="https://plus.google.com/share?url=https://holmesian.org/PHP7-PHP5-on-CentOS-at-the-same-time">
                <i class="fa fa-google-plus"></i>
            </a>

        </li>
   <li class="post-action hide-xs">
           <a class="post-action-btn btn btn--default tooltip--top" target="new" data-tooltip="分享至QQ空间" href="http://sns.qzone.qq.com/cgi-bin/qzshare/cgi_qzshare_onekey?url=https://holmesian.org/PHP7-PHP5-on-CentOS-at-the-same-time&title=PHP7与PHP5共存于CentOS7&site=Holmesian Blog/&pics=https://holmesian.org/usr/themes/Holmesian/image/avatar.jpg">
                <i class="fa fa-qq"></i>
            </a>
        </li>
         <li class="post-action hide-xs">
            <a class="post-action-btn btn btn--default" target="new" data-tooltip="分享至新浪微博" href="http://service.weibo.com/share/share.php?url=https://holmesian.org/PHP7-PHP5-on-CentOS-at-the-same-time/&appkey=Holmesian Blog/&title=PHP7与PHP5共存于CentOS7&pic=https://holmesian.org/usr/themes/Holmesian/image/avatar.jpg">
                <i class="fa fa-weibo"></i>
            </a>
        </li>

        
            <li class="post-action">
                <a class="post-action-btn btn btn--default" href="#disqus_thread">
                    <i class="fa fa-comment-o"></i>
                </a>
            </li>
        
        <li class="post-action">            <a class="post-action-btn btn btn--default" href="#mulu">
                <i class="fa fa-list"></i>
            </a>        </li>
    </ul>
</div>
<div id="disqus_thread">
     
<div class="comments" id="comments">
                    <div id="respond-post-1775" class="respond">
            <div class="cancel-comment-reply">
                <a id="cancel-comment-reply-link" href="https://holmesian.org/PHP7-PHP5-on-CentOS-at-the-same-time#respond-post-1775" rel="nofollow" style="display:none" onclick="return TypechoComment.cancelReply();">取消回复</a>            </div>
            <span id="response" class="widget-title">添加新评论</span>
            <form method="post" action="https://holmesian.org/PHP7-PHP5-on-CentOS-at-the-same-time/comment" id="comment-form">
                <div>
                                            <p class="comment-about">
                            <label for="author" class="required">称呼</label>
                            <input type="text" name="author" id="author" class="text" value=""/>
                        </p>
                        <p class="comment-about">
                            <label for="mail" class="required">邮箱</label>
                            <input type="email" name="mail" id="mail" class="text" value=""/>
                        </p>
                        <p class="comment-about">
                            <label for="url">网站</label>
                            <input type="url" name="url" id="url" class="text" placeholder="http://example.com" value=""/>
                        </p>
                                        <p>
                        <textarea rows="8" cols="50" name="text" class="text-area"></textarea>
                    </p>
                </div>
                <div class="col2">
                    <p>
                        <button type="submit" class="submit">提交评论</button>
                    </p>
                </div>
                <div class="clear"></div>
            </form>
        </div>
    </div>
</div>
        
    </div>
</article>
	       <footer id="footer" class="main-content-wrap">
    <span class="copyrights"> 博客已上线<span id=span_dt_dt></span><br>
 &copy; 2017 Holmesian Blog /
 Power By <a  target="_blank"  href="http://typecho.org/">Typecho</a> /
赣ICP备14005204号-1
<script>
var _hmt = _hmt || [];
(function() {
  var hm = document.createElement("script");
  hm.src = "//hm.baidu.com/hm.js?c8fabf8f64b4bab87971ab75ad332d7f";
  var s = document.getElementsByTagName("script")[0];
  s.parentNode.insertBefore(hm, s);
})();
</script>
</span>
</footer>
            </div>





    <div id="bottom-bar" class="post-bottom-bar"  
data-behavior="1">
              
                    <div class="post-actions-wrap">
    <nav>
        <ul class="post-actions post-action-nav">
            <li class="post-action"> 
              <a class="post-action-btn btn btn--default tooltip--top" href="https://holmesian.org/OCSP-Stapling"  data-tooltip="记录OCSP Stapling的两个问题"><i class="fa fa-angle-left"></i><span class="hide-xs hide-sm text-small icon-ml">PREVIOUS  </span></a>
                
            </li>
 <li class="post-action">
                
            <a class="post-action-btn btn btn--disabled" target="_blank">
<span class="hide-xs hide-sm text-small icon-mr">NEXT</span>
                    <i class="fa fa-angle-right"></i></a>
                
               
              
            </li>
        </ul>
    </nav>
   <ul class="post-actions post-action-share">
         <li class="post-action hide-lg hide-md hide-sm">
            <a class="post-action-btn btn btn--default btn-open-shareoptions"  href="#btn-open-shareoptions">
                <i class="fa fa-share-alt"></i>
            </a>
        </li>  <li class="post-action hide-xs">
          <a class="post-action-btn btn btn--default" target="new" data-tooltip="分享至Google"  href="https://plus.google.com/share?url=https://holmesian.org/PHP7-PHP5-on-CentOS-at-the-same-time">
                <i class="fa fa-google-plus"></i>
            </a>
        </li>

         <li class="post-action hide-xs">
            <a class="post-action-btn btn btn--default" target="new" data-tooltip="分享至新浪微博" href="http://service.weibo.com/share/share.php?url=https://holmesian.org/PHP7-PHP5-on-CentOS-at-the-same-time/&appkey=Holmesian Blog/&title=PHP7与PHP5共存于CentOS7&pic=https://holmesian.org/usr/themes/Holmesian/image/avatar.jpg">
                <i class="fa fa-weibo"></i>
            </a>
        </li>

        
            <li class="post-action">
                <a class="post-action-btn btn btn--default" href="#disqus_thread">
                    <i class="fa fa-comment-o"></i>
                </a>
            </li>
        
        <li class="post-action">
             <a class="post-action-btn btn btn--default" href="#mulu">
                <i class="fa fa-list"></i>
            </a>               
        </li>
    </ul>
</div>


                </div>

 <div id="share-options-bar" class="share-options-bar"  
data-behavior="1">

                
    <ul class="share-options">
        <li class="share-option">
            <a class="share-option-btn" target="new" href="http://service.weibo.com/share/share.php?url=https://holmesian.org/PHP7-PHP5-on-CentOS-at-the-same-time/&appkey=Holmesian Blog/&title=PHP7与PHP5共存于CentOS7&pic=https://holmesian.org/usr/themes/Holmesian/image/avatar.jpg">
                 <i class="fa fa-weibo"></i><span class="">Share on 新浪微博</span>
            </a>
        </li>
     
        <li class="share-option">
            <a class="share-option-btn" target="new" href="https://plus.google.com/share?url=https://holmesian.org/PHP7-PHP5-on-CentOS-at-the-same-time">
                <i class="fa fa-google-plus"></i><span>Share on Google</span>
            </a>
        </li>
    </ul>
</div>
<div id="share-options-mask" class="share-options-mask"></div>
     
   </div></div>
        <div id="about">
    <div id="about-card">
        <div id="about-btn-close">
            <i class="fa fa-remove"></i>
        </div>   
        <a href="#" > <img id="about-card-picture" src="https://holmesian.org/usr/themes/Holmesian/image/avatar.jpg"/></a>
        
            <h4 id="about-card-name">  Holmesian</h4>
 <h5 id="about-card-bio"><p>一个80末的独立博客,潜伏互联网,崇尚各种实用技术,记录并分享生活与成长.</p>
<SCRIPT language=javascript>
function show_date_time(){window.setTimeout("show_date_time()",1e3);var BirthDay=new Date("2007/07/03"),today=new Date,timeold=today.getTime()-BirthDay.getTime(),msPerDay=864e5,e_daysold=timeold/msPerDay,daysold=Math.floor(e_daysold),e_hrsold=24*(e_daysold-daysold),hrsold=Math.floor(e_hrsold),e_minsold=60*(e_hrsold-hrsold),minsold=Math.floor(60*(e_hrsold-hrsold)),seconds=Math.floor(60*(e_minsold-minsold));span_dt_dt.innerHTML=daysold+"天"+hrsold+"小时"+minsold+"分"+seconds+"秒"}
show_date_time();
</SCRIPT>


        
    </div>
</div>
   <div id="cover"style="background-color: #444444;"></div>


<!--- 简繁转换开始 ---><script>
var defaultEncoding = 2; // 1: 繁體, 2: 简体
var translateDelay = 0; //延迟时间,若不在前, 要设定延迟翻译时间, 如100表示100ms,默认为0
var cookieDomain = "https://holmesian.org/";
</script>
<script type="text/javascript" src="https://holmesian.org/usr/themes/Holmesian/js/cn_tw.js"></script>
<!--- 简繁转换结束 --->


    <!--SCRIPTS-->
<script src="https://holmesian.org/usr/themes/Holmesian/js/script.min.js" type="text/javascript"></script>
<script src="https://holmesian.org/usr/themes/Holmesian/js/kz.js" type="text/javascript"></script>
<script language="javascript" type="text/javascript">GenerateContentList();
</script>
 <script type="text/javascript">
        $(document).ready(function(){ 
            $('.tag sx').replaceWith('<a href="https://holmesian.org/sort/Daily/">日积月累</a></div>'); 
        });  
    </script> 
 

<div class="search_form">
        <form method="post" action="./" class="sosuo"> 
            <input class="search_key" name="s" autocomplete="off" placeholder="Enter search keywords..." type="text" value="" required="required">


<button type="submit" class="submit"><i class="fa fa-lg fa-search" id="bt"></i></button>
        </form>
        <span class="search_close"><i class="fa fa-close" id="close"></i></span>
    </div>

<script type="text/javascript" src="https://holmesian.org/usr/plugins/HighSlide/js/highslide.packed.js"></script>
<script type="text/javascript">
//<![CDATA[
hs.graphicsDir = "https://holmesian.org/usr/plugins/HighSlide/css/graphics/";
hs.fadeInOut = true;
hs.transitions = ["expand","crossfade"];
hs.lang.creditsText = "&copy; holmesian.org";
hs.lang.creditsTitle = "&copy; holmesian.org";
hs.creditsHref = "https://holmesian.org";
hs.creditsPosition = "bottom center";
hs.outlineType = "beveled";
hs.wrapperClassName = "borderless";
//]]>
</script>
		 
    </body>
</html>
